Author Topic: mpfi rpms idle between 1-2k. rpms constantly reving.  (Read 2237 times)

0 Members and 1 Guest are viewing this topic.

Offline ej25

  • n00b
  • Join Date: Jun 2010
  • Posts: 20
  • Karma: 0

  • Activity
    0%
mpfi rpms idle between 1-2k. rpms constantly reving.
« on: April 29, 2012, 01:44:09 pm »
http://youtu.be/ddYsmgxp-yQ

Please check the vaccum lines too. I think I have those wired up correctly .

No CEL.

Throttle cable is not tight.

What do you all think it could be?

Thanks!

Offline rbwdriven

  • Administrator
  • Steppin' it up!
  • *****
  • Join Date: May 2009
  • Posts: 5489
  • Karma: 63

  • Activity
    0%
Re: mpfi rpms idle between 1-2k. rpms constantly reving.
« Reply #1 on: April 29, 2012, 04:35:18 pm »
Here you go.

possible hunting idle.  Did you just do the swap?

low on coolant.

But it is the theory of hunting idle ( idle air control valve)

http://www.youtube.com/watch?v=tUkCCwqU3eU

Here is your vacuum diagram.


Offline ej25

  • n00b
  • Join Date: Jun 2010
  • Posts: 20
  • Karma: 0

  • Activity
    0%
Re: mpfi rpms idle between 1-2k. rpms constantly reving.
« Reply #2 on: April 29, 2012, 06:06:34 pm »
If i connect the map sensor "21" then the car has the crazy idle. If i do no connect "21" then the car runs fine.

Offline ej25

  • n00b
  • Join Date: Jun 2010
  • Posts: 20
  • Karma: 0

  • Activity
    0%
Re: mpfi rpms idle between 1-2k. rpms constantly reving.
« Reply #3 on: April 29, 2012, 06:08:45 pm »
also cleaned the IACV. Took it out. cleaned it with brake cleaner. did nothing. There is something up with the vaccum hoses.

Offline rbwdriven

  • Administrator
  • Steppin' it up!
  • *****
  • Join Date: May 2009
  • Posts: 5489
  • Karma: 63

  • Activity
    0%
Re: mpfi rpms idle between 1-2k. rpms constantly reving.
« Reply #4 on: April 29, 2012, 07:29:58 pm »
pm me your cell.

I'll take a picture of mine.

maybe that will help ya.

Offline Fulthrottlefreak

  • Full Throttle Freak
  • I <3 My EF
  • ***
  • Join Date: Jan 2012
  • Posts: 814
  • Karma: 1
  • Swag Wagon rolling

  • Activity
    0%
    • Doug's Facebook
Re: mpfi rpms idle between 1-2k. rpms constantly reving.
« Reply #5 on: April 29, 2012, 07:51:26 pm »
Sounds like your FIT-valve maybe be clogged/dirty. This may help...
http://www.youtube.com/watch?feature=endscreen&NR=1&v=2n8KZqqSEaY
89 Wagovan EE2,91 Si Hatch
H.E.A.R.T .

Offline ej25

  • n00b
  • Join Date: Jun 2010
  • Posts: 20
  • Karma: 0

  • Activity
    0%
Re: mpfi rpms idle between 1-2k. rpms constantly reving.
« Reply #6 on: April 29, 2012, 10:23:54 pm »
update.

Just found out that the throttle body on my car is off of a 96+ gsr, there is only one hole inside of the throttle body and I have not FTIV, only a IACV. Also the TPS is riveted on.

I can not budge the adjustmen t screw for idling, its stuck.

The car ran great with the vacuum hose not connected to the map sensor, but after starting the car back up the CEL came on with Engine code 5, MAP not connected . Connected the vacuum lines correctly . Still idles between 1-2k.

Should i keep this and make it work or actually get a  throttle body thats intended for the mpfi swap? This whole fiasco is making me want to just do a complete engine swap and not worry about fitting pieces together.

.

Offline Fulthrottlefreak

  • Full Throttle Freak
  • I <3 My EF
  • ***
  • Join Date: Jan 2012
  • Posts: 814
  • Karma: 1
  • Swag Wagon rolling

  • Activity
    0%
    • Doug's Facebook
Re: mpfi rpms idle between 1-2k. rpms constantly reving.
« Reply #7 on: April 29, 2012, 10:40:13 pm »
Well if you do the complete swap.. You wouldnt have to worry about fitment cause everythin g will be correct and not rigged...
89 Wagovan EE2,91 Si Hatch
H.E.A.R.T .

Offline ej25

  • n00b
  • Join Date: Jun 2010
  • Posts: 20
  • Karma: 0

  • Activity
    0%
Re: mpfi rpms idle between 1-2k. rpms constantly reving.
« Reply #8 on: May 21, 2012, 12:01:04 pm »
The car is now fixed....

I needed a EACV. All of the local part stores online/local do not make one for the ef si model so I grabbed one from a 90-91 integra. Bolted the EACV on and the car started up just fine. The project is finally complete.

Thank you all for your help! Much appreciat ed!


 

Related Topics

  Subject / Started by Replies Last post
20 Replies
3082 Views
Last post January 24, 2010, 10:24:31 pm
by S.Brewer
2 Replies
1115 Views
Last post February 28, 2010, 06:12:48 pm
by fastsmurf04
15 Replies
3107 Views
Last post September 29, 2011, 11:44:36 pm
by wiggles
7 Replies
1685 Views
Last post November 19, 2011, 08:16:20 am
by Lando79
11 Replies
1683 Views
Last post January 27, 2012, 10:59:15 pm
by Mass13