Author Topic: need opinions if this sounds like bad distributor?  (Read 1581 times)

0 Members and 1 Guest are viewing this topic.

Offline bluZZC90

  • n00b
  • Join Date: Dec 2013
  • Posts: 2
  • Karma: 0

  • Activity
    0%
need opinions if this sounds like bad distributor?
« on: June 28, 2015, 07:10:46 am »
i want to get people's opinions what my problem could be?,  to narrow it down as much as possible, before assuming and just buying parts . . .my car is a 90 honda crx si with 255,000 miles & ZC DOHC

i was on highway going 60mph, then started losing power, stalling out towards the shoulder, it was making sputterin g sounds while doing it,   then it would'nt start, just crank over and over while making sputterin g and a few backfire sounds out the tailpipe, but would'nt start. i got it towed home.

i saw that the base of the distribut or rotor looked melted around the shaft it goes onto, the rotor spins around normally if i cranked it over though, and the rotor still had the rotor screw in place, and it was'nt loose. the cap looked brand new from the inside of it, didnt have any red dust or residue or signs of anything.
heres a pic of the rotor :   

it has spark, main relay clicks turning the key "on", fuel comes out of disconnec ted fuel filter hose when cranking it over, battery is 12.18volt s , starter and alt are good, no fuses blown, timing belt is good, timing looks lined up same as before, it has gas, spark plugs looked like-new condition, no ECU codes either.

i tried putting a new cap and rotor got from autozone on, making sure the plug wires in right order, it still did'nt start?, did same thing, just cranked and cranked but not start?

most people think i need a new distribut or, that the bearing probably failed and caused the rotor to melt, but i read that if a distribut or fails, you hear a screechin g noise coming from the distritub or and theres usually red dust or oily residue inside your distribut or cap, and i did'nt have either of those on mine?
if my distribut or did go out, it did it suddenly, after car was driving perfect, and i did'nt have any symptoms leading up to it?

after trying to narrow it down myself, and hearing opinions on forums, should i just assume and go ahead and buy a whole new distribut or ?
or would it be better to have a mobile mechanic take a look at it, so he can tell me for sure if its the distribut or or not ? so i know before buying parts

any thoughts or input is cool, thanks

Offline rbwdriven

  • Administrator
  • Steppin' it up!
  • *****
  • Join Date: May 2009
  • Posts: 5489
  • Karma: 63

  • Activity
    0%
Re: need opinions if this sounds like bad distributor?
« Reply #1 on: July 07, 2015, 07:52:41 pm »
Things to check.

Have checked the voltage at the ignitor coil.

I know my friend had the same issue with car running like hell and it was his ignition switch.

Taking the distribut or out of the equation is pretty easy.

Unbolt and remove from car.  Spin and listen for noise also look for crap in the cap or around the distribut or.  Turn upside down and let "stuff" fall out on white paper towel.

I've had two distribut ors let me down.  Both have been the rotor screw backed out and let the rotor spin.

I've had one ignitor module fail and it would not let the car start.  Gave me a really weak spark color.

Checked by turning car over while holding a spark plug against the block.



 

Related Topics

  Subject / Started by Replies Last post
8 Replies
1903 Views
Last post August 31, 2009, 09:21:24 pm
by S.Brewer
32 Replies
5305 Views
Last post August 27, 2010, 01:09:26 pm
by S.Brewer
6 Replies
1628 Views
Last post January 11, 2011, 08:23:45 pm
by slowstefan
11 Replies
2080 Views
Last post November 27, 2011, 01:42:51 am
by bfrman
1 Replies
907 Views
Last post November 11, 2012, 06:37:25 pm
by rbwdriven